
Hand-on	session	FFYS7086	23.5.2022
Practical	work	on	MRI	signal	modelling	and	processing	13:00-
17:00
Harri	Merisaari,	haanme@utu.Ii
	

Learning	objectives:
	
WORK1

-       Basic	ITK-SNAP	use	for	visualization	and	quality	control	of	3D	and	4D	medical	imaging	data
-       Basic	T1W	brain	processing	with	Freesurfer	for	volymetry	and	cortex	surface	measures
-       Basic	use	for	Freesurfer’s	freeview	tool	for	visualization	and	quality	control
	
WORK2

-       Basic	DTI	processing	with	fsl	toolbox	for	DTI	scalar	measurements
-       Basic	DTI	processing	with	DSIstudio	for	tracktography

	
Data:
-       Hands_on_data_v1	https://Iilesender.funet.Ii/?s=download&token=a05ee396-dc1d-4e27-
a8db-bec58f147246

-       The	original	data	used	in	the	session	is	freely	available	from
https://www.nitrc.org/projects/multimodal

	
Platform:
-       The	exercises	are	designed	to	be	run	at	UTU	Quantum	109	classroom	Windows	machines,
with	VMware	virtual	desktop
o  Search	with	name	VMware	Workstation	16	Player	in	a	classroom	workstation

-       Optionally,	you	can	do	all	of	the	excercises	in	you	own	computer,	if	it	can	run	VMware	virtual
machine	images

-       Optionally,	you	can	install	the	used	software	natively.	For	this,	please	install	required	software
for	WORK1	and	WORK2,	respectively
o  Please	note	that	some	of	the	software	is	not	natively	supported	in	all	main	OS.

	
	
	
	

WORK1:	Instructions	for	processing	anatomical	T1W	(3D)
image:

	
1.   Download	and	extract	virtual	machine	image:
https://Iilesender.funet.Ii/?s=download&token=fIbc5e91-3804-4c2f-9173-b87acb22478c

-       Requires	software	installations:	ITK-SNAP	(supported	in	Win,	OS	X,	Linux),	Freesurfer
(supported	in	OS	X,	Linux)
	

2.   Start	VMware	Workstation	16	Player
	

3.   Start	virtual	the	machine	(Ubuntu	20.04	LTS)
	
4.   Locate	pre-downloaded	data	folder	Hands_on_data_v1	at	the	Desktop

https://filesender.funet.fi/?s=download&token=a05ee396-dc1d-4e27-a8db-bec58f147246
https://www.nitrc.org/projects/multimodal
https://filesender.funet.fi/?s=download&token=ffbc5e91-3804-4c2f-9173-b87acb22478c


	
5.   (Quality	Control)	with	ITK-SNAP	(start	from	command	line	by	running	command	itksnap)

	
1.   Open	(File	>	Open	Main	Image	…)	T1W:
MMRR-3T7T-2-
1_multimodal/3T/Landman_3252_20110818_366802201_301_WIP_MPRAGE_SENSE_MPRAGE_SENSE.nii.gz
	

2.   Navigate	through	3D	data)	Scroll	through	3D	image	along	transaxial,	sagittal	and	coronal
slices

3.   (Adjust	visualization	contrast)	Select	‘Tools	>	Layer	Inspector…’,	then	‘Contrast’	tab

4.   (Detect	basic	properties	of	the	image)	Adjust	image	contrast	so	that	you	can	see
variation	in	the	brain	white	matter	and	thalamus
(http://en.wikipedia.org/wiki/Thalamus)	more	clearly



5.   Is	there	inhomogeneity	(white	matter	being	brighter/darker	in	lobes	of	the	brain)	in	the
white	matter?	If	yes,	where?
	

6.   Is	contrast	good	enough	to	recognize	thalamus	region	in	this	image?	With	this	data,	is	it
possible	to	see	medial,	anterior	and	lateral	subnuclei
(https://en.wikipedia.org/wiki/Thalamus#/media/File:Thalmus.png)	of	the	thalamus?

	
6.   (Image	co-registration):

	
1.   Add	another	repetition	of	the	same	data:
MMRR-3T7T-2-
1_multimodal/3T/Landman_3252_20110818_366802201_801_WIP_MPRAGE_SENSE_MPRAGE_SENSE.nii.gz
	

2.   Click	on	regions	of	image,	notice	that	the	T1W	intensity	value	varies.	This	difference	can
be	used	to	calculate	test-retest	repeatability,	standard	error	of	measurement	etc.	at
voxel	level.
	

3.   Run	co-registration:	Tools	>	Registration	…	>		Run	Registration
·      After	registration	Iinishes	verify	the	results,	e	g	select	between	images	and	look	at
transaxial,	sagittal	and	coronal	views	for	difference	in	orientation

	
4.   Try	different	parameters.

·      Goodness-of-Fit	criteria:	Mutual	Information,	Cross-Correlation,	Intensity
difference

·      Coarse	scale	and	Iine	scale	smoothing	ratio	(1x	is	no	smoothing,	bigger	number
means	more	smoothing	i	e	more	coarse	scale	coregistration)

·      Also	manual	alignment	is	an	option
	

5.   Can	you	manage	to	create	an	adequate	aligment	between	the	images,	based	on	visual
examination?
	

7.   (Gray	matter	and	subcortical	regions	segmentation	with	Freesurfer)	with	command	line:
	

1.   Goto	data	folder:	cd	Desktop/Hands_on_data_v1
	

2.   Create	output	folder:	mkdir	Freesurfer_output
	

3.   Set	environmental	variable	for	Freesurfer	output:
	



export	SUBJECTS_DIR=/home/ubuntu/Desktop/Hands_on_data_v1
	

4.   Go	to	data	subfolder:	cd	MMRR-3T7T-2-1_multimodal/3T
	

5.   Start	segmentation	(1st	portion	with	-autorecon1,	all	steps	can	be	run	with	-all):
	
recon-all	–autorecon1	–i	
Landman_3252_20110818_366802201_301_WIP_MPRAGE_SENSE_MPRAGE_SENSE.nii.gz
–subjid	Landman_T1W
	-	At	classroom	Quantum	109	machine	with	VMware	virtual	machine,	do	not	run	the
command	(takes	some	6	hours	to	Iinish),	instead	use	pre-calculated	results	in	folder
Freesurfer_output_precalculated	and	go	directly	to	next	item	8	(quality	Control	for
segmentation)
	

6.   Verify	that	the	segmentation	starts	properly.	This	step	runs	through	various	steps,
creating	segmentation	for	cortex.

	
7.   Wait	for	the	segmentation	to	Iinish	OR	alternatively
	

8.   	(Quality	Control	for	segmentation)	with	Freeview,	run	(from	command	line):
	
1.   Start	from	command	line:	freeview
	

2.   Open	T1W	(File	>	Load	Volume…	>	Select	volume	Iile):
Freesurfer_output_precalculated/Landman_T1W/mri/T1.mgz		(Freesurfer
compressed	image	format)
	

3.   Open	segmentation	results	atlas	at	individual	space	(File	>	Load	Volume…	>	Select
volume	Iile):

Freesurfer_output_precalculated/Landman_T1W/mri/aparc+aseg.mgz
	

4.   Open	segmentation	results	(left	hemisphere	WM/GM)	surface	(File	>	Load	Volume…	>
Load	Surface…):

Freesurfer_output_precalculated/Landman_T1W/surf/lh.white
Freesurfer_output_precalculated/Landman_T1W/surf/rh.white
Freesurfer_output_precalculated/Landman_T1W/surf/lh.pial.T1
Freesurfer_output_precalculated/Landman_T1W/surf/rh.pial.T1
	

5.   Open	label	Iile	for	corrected	defects	(File	>	Load	Volume…	>	Select	volume	Iile):
Freesurfer_output_precalculated/Landman_T1W/mri/surface.defects.mgz

·      These	labels	give	hints	of	regions	where	the	segmentation	for	boundary	surfaces
had	difIiculties,	and	problem	in	segmentation	may	be	found	near	or	at	them

https://surfer.nmr.mgh.harvard.edu/fswiki/ReconAllTableStableV6.0


	
6.   Can	you	detect	defects	in	GM/WM	segmentation	and/or	in	GM/brain	segmentation
surface?	If	yes,	where?
·      Try	to	observe	the	image	in	all	three	orthogonal	views	simultaneously,	as
individual	2D	view	may	sometimes	give	wrong	impression	of	where	the	surface	is
located	in	3D	space

	
9.   	(Contrast-to-Noise	Ratio,	explore	effect	of	inhomogeneity	correction)	with	command	line
	
1.   Calculate	Contrast-to-Noise	Ratio	(CNR,	noise	vs	brain	gray/white	matter	difference)	of
original	converted	T1W	image:
	
mri_cnr	Freesurfer_output_precalculated/Landman_T1W/surf
Freesurfer_output_precalculated/Landman_T1W/mri/orig.mgz
	

2.   Calculate	Contrast-to-Noise	Ratio	(CNR)	of	original	inhomogeneity-corrected	T1W
image:
	
mri_cnr	Freesurfer_output_precalculated/Landman_T1W/surf
Freesurfer_output_precalculated/Landman_T1W/mri/orig_nu.mgz
	

3.   Start	from	command	line:	freeview
	

4.   Visualize	and	compare	the	two	images
	

5.   Has	the	inhomogeneity	correction	improved	CNR	(i	e	in	mri_cnr	output,	MPRAGE	T1W
CNR	should	be	some	where	2.0-5.0)?	If	yes,	can	it	be	seen	in	visual	inspection?

	
At	this	point,	you	have	successful	segmentation	of	GM/WM	and	subregions,	and	parcellations	for
Region-of-Interest	(ROI)	level	analysis.	The	ROI	mean	values,	and	radiomic	feature	extraction	can
be	further	extracted	using	these	ROIs.
	
	
	
	

WORK2:	Instructions	for	processing	Diffusion	Tensor	Image
(DTI,	4D	image):
	
1.   Download	and	extract	virtual	machine	image:
https://Iilesender.funet.Ii/?s=download&token=a6f7d406-c4e4-4dd5-a103-4b5c77e962cd

-       Requires	software	installations:	fsl	(OS	X,	Linux),	DSIstudio	(Windows,	Linux),	docker
(Windows,	OS	X,	Linux)	or	mrtrix	3	as	native	installation
	

2.   Start	the	virtual	machine	(Ubuntu	20.04	LTS)
	

3.   (Quality	control)	With	ITK-SNAP	(run	itksnap	from	command	line):
-       Open	DWI	image:
Landman_3252_20110818_366802201_501_WIP_DTI_2_2_iso_SENSE_DTI_2_2_iso.nii.gz

-       Select	‘Tools	>	Layer	Inspector…’,	then	‘General’	tab

https://filesender.funet.fi/?s=download&token=a6f7d406-c4e4-4dd5-a103-4b5c77e962cd


-       Scroll	through	the	diffusion	encoding	direction	volumes.	Find	locations	and	index
number	of	all	B0	images	(without	diffusion	weighting)	in	the	4D	image.	They	are
recognized	by	being	more	bright	than	diffusion	weighted	images,	which	have	lower
intensity	due	to	signal	loss	from	water	motion.
	

-       Re-adjust	display	color	range	to	see	B0	volumes	and	diffusion	enconding	direction
volumes	clearly
	

-       Which	component	numbers	are	B0s	(i	e	no	diffusion	weighting)?
	

-       Browse	through	direction	images,	look	for	motion	and	other	artefacts
	

-       Was	there	detectable	inter-volume	motion	in	this	image?	If	yes,	between	which	volumes
there	was	detectable	motion	occurring?
	

4.   (Fusion	imaging	for	quality	control	purposes):
	
-       Open	DWI	image:
Landman_3252_20110818_366802201_501_WIP_DTI_2_2_iso_SENSE_DTI_2_2_iso.nii.gz
	

-       Add	T1W	image	with	ITK-SNAP	(File	>	Add	Another	Image	…	):
Landman_3252_20110818_366802201_301_WIP_MPRAGE_SENSE_MPRAGE_SENSE.nii.gz
	

-       Adjust	overlay	for	visualization	back	and	forth	to	see	DWI	deviating	from	anatomical
reference	in	T1W	at	certain	locations	(Tools	>	Layer	Inspector…	>	General	>	Additional
Images	>	slide	bar)
	

-       Can	you	detect	DWI	deformations	from	normal	brain	anatomy,	intensity	anomalies?	If
yes,	where?
	

5.   (Artefact	removal,	using	mrtrix	tools	inside	docker	container)	With	command	line:
	
-       Goto	data	folder	Hands_on_data_v1
	

-       Start	docker	with	command:
	
sudo	docker	run	–it	–v	$(pwd):/data	haanme/mrtrix:3.0.2
	



-       If	you	have	trouble	starting	the	container,	try	pulling	it	Iirst	sudo	docker	pull
haanme/mrtrix:3.0.2

-       This	starts	the	container	mrtrix	version	3.0.2	in	haanme	repository
-       Starting	location	(which	should	be	Desktop/Hands_on_data_v1)	is	mounted	to
/data	directory	(i	e	all	content	is	accessed	from	there)

	
-       Goto	data	folder	inside	mrtrix:3.0.2	Linux	container:
	
cd	/data
	

-       Run	Marchenko-Pastur	theorem	(for	signal-noise	threshold)	based	PCA	(Principal
Component	Analysis)	denoising	with	command:
	
dwidenoise	MMRR-3T7T-2-
1_multimodal/3T/Landman_3252_20110818_366802201_501_WIP_DTI_2_2_iso_SENSE_DTI_2_2_iso.nii.gz
Landman_501_DTI_denoised.nii.gz
	

-       Run	Gibbs	artefact	removal	with	command:
	
mrdegibbs	MMRR-3T7T-2-1_multimodal/3T/Landman_501_DTI_denoised.nii.gz
Landman_501_DTI_denoised_dg.nii.gz
	

-       Exit	from	docker	with	command:	exit
	

6.   (Distortion	correction	with	anatomical	reference,	because	we	do	not	have	blip	direction
image	with	this	data)	With	command	line:

	
-       Go	to	data	folder	Hands_on_data_v1
	

-       Start	docker	with	command:
	

sudo	docker	run	–it	–v	$(pwd):/data	haanme/mrtrix:3.0.2
	

-       Go	to	data	folder	inside	container:	cd	/data
	

-       Create	working	directory:	mkdir	SynB0
	

-       Extract	1st	volume	(which	is	B0	image	without	diffusion	weighting)	from	DWI	image	to
working	directory:
fslroi	Landman_501_DTI_denoised_dg.nii.gz	SynB0/b0.nii.gz	0	1
-       0	means	starting	index,	1	means	1	consecutive	volumes	extracted,	i	e	only	the	1st
volume

	
-       Copy	T1W	image	to	working	directory:
cp	MMRR-3T7T-2-
1_multimodal/3T/Landman_3252_20110818_366802201_301_WIP_MPRAGE_SENSE_MPRAGE_SENSE.nii.gz
SynB0/T1.nii.gz
	

-       Generate	acquisition	parameters	for	TOPUP	distortion	correction:	printf	”0	-1	0
0.01\n0	1	0	0.01”	>	SynB0/acqparams.txt
-       You	can	also	use	text	editor	to	create	the	Iile

	



-       Exit	from	docker	with	command:	exit
	

-       Verify	that	the	created	Iiles	are	properly	created	into	Hands_on_data_v1/SynB0:
-       b0.nii.gz,	b0	image	with	distortion
-       T1.nii.gz,	T1-weighted	anatomical	image,	used	as	reference	to	estimate	the
amount	of	distortion	in	b0.nii.gz

-       acqparams.txt,	ASCII	Iile	containing	correction	parameters
	

-       Continue	in	Linux	command	line.	At	data	folder,	start	SynB0	distortion	estimation	with
command:
sudo	docker	run	–-rm	–v	$(pwd)/SynB0:/INPUTS/	-v	$(pwd)/SynB0:/OUTPUTS/	-
v	$(pwd)/license.txt:/extra/freesurfer/license.txt	–user	$(id	-u):$(id	-g)
hansencb/synb0:v1.1
-       At	classroom	Quantum	109	machine	with	VMware	virtual	machine,	do	not	run	the
command	(takes	some	3	hours	to	Iinish),	instead	use	pre-calculated	results	in
folder	SynB0_precalculated	and	go	directly	to	next	item	7	(Visualization	of
correction	effect)

-       SynB0	folder	should	be	in	the	execution	directory
-       Input	and	output	folders	for	the	script	are	mounted	as	the	same:	SynB0,	input	is
read	from	/INPUT	folder	inside	the	container

-       The	container	is	synb0	from	hansencb	repository
-       Script	uses	Freesurfer	for	which	license	Iile	need	to	be	given	explicitly:	license.txt

	
-       Wait	for	task	to	end	OR	use	precalculated	Iiles	in	SynB0_precalculated

	
7.   (Visualization	of	correction	effect)	Inspect	preprocessed	b0	image	with	ITK-SNAP

	
-       Open	original	distorted	image:	SynB0/b0_all.nii.gz
	

-       Add	preprocessed	image:	SynB0/b0_all_topup.nii.gz
	

-       Add	anatomical	reference:
Landman_3252_20110818_366802201_301_WIP_MPRAGE_SENSE_MPRAGE_SENSE.nii.gz
	

-       Are	there	improvements	after	corrections?	Can	you	Iind	inaccuracies	left	in	the
distortion	corrected	image?
	

8.   (Eddy	current	and	motion	correction,	DTI	modelling)	With	command	line:
	

-       Go	to	data	folder:	Hands_on_data_v1
	

-       Start	docker	with	command:
	

sudo	docker	run	–it	–v	$(pwd):/data	haanme/mrtrix:3.0.2
	

-       Goto	data	folder	inside	Linux	container:	cd	/data
	

-       Create	brain	mask	image	with	brain	extraction	tool	bet2:
-       Extract	corrected	b0	image:
fslroi	SynB0/b0_all_topup.nii.gz	b0_1st_topup	0	1

-       Create	brain	mask:
bet2	SynB0/b0_1t_topup.nii.gz	b0_1st_topup_brain	–m



	
-       Make	copy	of	b-vector	Iile	and	b-value	Iile

-       cp	MMRR-3T7T-2-
1_multimodal/3T/Landman_3252_20110818_366802201_501_WIP_DTI_2_2_iso_SENSE_DTI_2_2_iso_bvecs
bvecs

-       cp	MMRR-3T7T-2-
1_multimodal/3T/Landman_3252_20110818_366802201_501_WIP_DTI_2_2_iso_SENSE_DTI_2_2_iso_bvals
bvals

	
-       Remove	last	frame	with	motion	from	the	DWI

-       Open	the	bvecs	and	bvals	Iile	with	text	editor,	then	remove	last	frame	from	them
(number	34).
-       bvecs	Iile	has	three	rows,	the	diffusion	encoding	directions	are	in	the
columns

-       bvals	Iile	has	one	row,	the	used	b-values	for	b=0	s/mm2	and	b=700	s/mm2
volumes	in	bvals	Iile,	and	corresponding	vectors	in	bvec	Iile

-       Use	nano	at	command	line	or	other	text	editor
-       Create	dwi.nii.gz	Nifti	image	without	last	volume	34:
fslroi	MMRR-3T7T-2-
1_multimodal/3T/Landman_3252_20110818_366802201_501_WIP_DTI_2_2_iso_SENSE_DTI_2_2_iso.nii.gz
dwi.nii.gz	0	33

	
-       Create	index	parameter	Iile	for	fsl	eddy	tool	(33	is	now	the	number	of	volumes	in	the	4D
DWI	image):
-       At	command	line:
for	((i=1;	i<=33;	i+=1));	do	indx="$indx	1";	done
echo	$indx	>	index.txt

-       You	can	also	create	the	index.txt	Iile	with	text	editor	(one	row	with	33	‘1’	separated
by	spaces)

	
-       Apply	joint	eddy	current	and	motion	correction	step	with	command:
eddy_openmp	--imain=/data/dwi.nii.gz	--index=/data/index.txt	--
mask=/data/b0_1st_topup_brain_mask.nii.gz	--acqp=/data/SynB0/acqparams.txt
--bvecs=/data/bvecs	--bvals=/data/bvals	--topup=/data/SynB0/topup	--
out=/data/eddy_outputs
-       At	classroom	Quantum	109	machine	with	VMware	virtual	machine,	do	not	run	the
command	(takes	some	3	hours	to	Iinish),	instead	of	eddy_outputs	folder,	use	pre-
calculated	results	in	folder	eddy_output_precalculated	and	go	directly	to	next
item	9	(Visualization	of	correction	effect)

	
-       Wait	for	the	step	to	Iinish	OR	use	results	in	folder	eddy_output_precalculated
	

-       Exit	from	docker	with	command:	exit
	

9.   (Visualization	of	correction	effect)	Inspect	effect	of	distortion/eddy/motion	correction	with
ITK-SNAP
	
-       Open	original	distorted	image:	dwi.nii.gz
	

-       Open	preprocessed	image	(File	>	Add	another	Image	..):	eddy_outputs.nii.gz
	

-       Can	you	detect	effects	of	correction?	If	yes,	where?



	
10.             Apply	fsl	toolkit’s	DTI	model	Iitting	with	command	line:

	
-       Go	to	data	folder:	Hands_on_data_v1
	

-       Start	docker	with	command:	docker	run	–it	–v	$(pwd):/data	haanme/mrtrix:3.0.2
	

-       Goto	data	folder	inside	Linux	container:	cd	/data
	

-       Fit	Diffusion	Tensor	model	to	the	DWI	data	(note	to	use	rotated	b-vectors	because	data
is	rotated):
dtimit	–k	eddy_outputs.nii.gz	–r	eddy_outputs.eddy_rotated_bvecs	–b	bvals	–m
SynB0/b0_1t_topup_brain_mask.nii.gz	–o	Landman_501
-       Using	corrected	image	eddy_outputs.nii.gz
-       Using	rotated	diffuion	encoding	direction	vectors
eddy_outputs.eddy_rotated_bvecs

-       This	created	DTI	scalar	maps	(FA,	MD)	eigenvectors	(V1,	V2,	V3)	an	eigenvalues
(L1,	L2,	L3)

	
-       Calculate	Radial	Diffusivity	(RD)	as	average	of	2nd	and	3rd	eigenvalues	of	modelled
tensors:
fslmaths	Landman_501_L2.nii.gz	–add	Landman_501_L3.nii.gz	–div	2.0
Landman_501_RD.nii.gz
-       This	calculates	RD	=	(L2	+	L3)/2.0

	
-       Exit	from	docker	with	command:	exit

	
11.             (Visualize	DTI	scalar	maps)	With	ITK-SNAP:

	
-       Open	Fractional	Anisotropy	scalar	map:	Landman_501_FA.nii.gz

-       Is	the	axonal	integrity	high	in	the	brain	white	matter	(i	e	FA	values	are	>	0.3)?
-       Can	you	Iind	clear	artefacts,	i	e	exceptionally	low/high	FA	values	from	what	is
expected	by	anatomy?	If	yes,	where?

	
-       Open	Mean	Diffusivity	map	(File	>	Add	another	Image	..):	Landman_501_MD.nii.gz

-       Cerebropinal	Iluid	(CSF)	characteristics	are	close	to	free	water	in	terms	of
diffusion.	Are	the	CSF	values	a	expected,	i	e	near	3.0	x	10-3	mm2/s?

	
-       Open	Axial	Diffusivity	(AD,	i	e	the	1st	eigenvalue)	scalar	map	(File	>	Add	another	Image
..):	Landman_501_L1.nii.gz
	

-       Open	Radial	Diffuivity	scalar	map	(File	>	Add	another	Image	..):
Landman_501_RD.nii.gz
	

-       Observe	FA,	MD,	AD,	RD	together	visually.	Do	you	see	obvious	artefacts/noise	in	the
images?
	

-       Observe	DTI	scalar	values	in	Corpus	Callosum
(https://en.wikipedia.org/wiki/Corpus_callosum),	where	all	axons
(and	therefore	diffusion	to	large	extent)	are	expected	to	be	in	one	direction	only	(along
left-right	axis).	Are	the	values	as	expected?	If	not,	where?
	



12.             (Quality	Control	summary	of	distortion/eddy/motion	corrections)	with	command	line:
-       Go	to	data	folder:	Hands_on_data_v1
-       Start	docker	with	command:	docker	run	–it	–v	$(pwd):/data	haanme/mrtrix:3.0.2
-       Goto	data	folder	inside	Linux	container:	cd	/data/eddy_outputs_precalculated
-       Run	fsl’s	quality	control	tool	for	eddy	outputs:	eddy_quad	eddy_outputs	–idx
../index.txt	–par	../acqparams.txt	–m	SynB0/b0_1st_topup_brain_mask.nii.gz	–b
bvals	–g	bvecs	–f	SynB0/b0_1st_topup.nii.gz
-       The	output	should	say	that	you	have	1	b0	and	32	diffusion	encoding	directions

-       Verify	adequate	quality	of	processed	data:	eddy_outputs.qc/qc.pdf
-       Is	the	observed	motion	(estimate	from	correction	parameters)	to	any	direction
bigger	than	voxel	size?

-       Is	the	motion	in	degrees	less	than	5	deg?
-       How	is	the	motion	(Translation/Rotation/Displacement)	distributed	across
acquisition	time	(noting	that	the	volumes	can	be	here	considered	as	time	points)?
-       Regular/irregular	motion?
-       Constant	gradual	motion	to	certain	direction?
-       SpeciIic	time	points	where	subject	moved	more/exceptionally	much?

-       In	last	Iigure	of	the	QC	Iile,	is	there	speciIic	volume(s)	(depicted	by	columns)	which
have	a	lot	of	slice	deviating	from	average	slice	signal	intensity	(i	e	indicating	signal
dropout	likely	due	to	motion).	If	yes,	do	you	see	corresponding	motion	in	the
motion	graphs	above?

-       Exit	from	docker	with	command:	exit
	

13.             (Tracktography)	DSIstudio:
	
1.   Start	DSIstudio	with	command:
dsi_studio
	

2.   Open	pre-processed	image	(select	Step	T1:	Open	Source	Images)	with	Iile:
Landman_3252_20110818_366802201_501_WIP_DTI_2_2_iso_SENSE_DTI_2_2_iso.nii.gz

-       Load	b-values	(B-table	window,	Files	>	Open	bval…):
Landman_3252_20110818_366802201_501_WIP_DTI_2_2_iso_SENSE_DTI_2_2_iso.bvals

-       Load	b-vectors	(B-table	window,	Files	>	Open	bvec…):
Landman_3252_20110818_366802201_501_WIP_DTI_2_2_iso_SENSE_DTI_2_2_iso.bvecs
	

3.   Reconstruct	(select	Step	T2:	reconstruction)	with	Iile:
Landman_3252_20110818_366802201_501_WIP_DTI_2_2_iso_SENSE_DTI_2_2_iso.nii.gz.src.gz
-       Select	DTI	(Diffusion	Tensor	Imaging)	radiobutton	below	the	displayed	images
instead	of	GQI	(Q-ball	Imaging)

-       Start	reconstruction	by	clicking	Run	Reconstruction
-       Close	the	window
	

4.   Fiber	tracking	(select	Step	T3:	Fiber	Tracking	&	Visualization)	with	Iile:
Landman_3252_20110818_366802201_501_WIP_DTI_2_2_iso_SENSE_DTI_2_2_iso.nii.gz.src.gz.dti.mib.gz

	
5.   Perform	deterministic	trackography

·      Change	these	parameters	from	default,	to	avoid	overloading	of	the	platform
-       ‘Tracking	Threshold’:	0.3	(streamlines	do	not	pass	through	voxel	having	less
than	0.3	FA	in	them,	e	g	in	CerebroSpinal	Fluid)

-       ‘Angular	Threhold’:	60	(streamlines	do	not	continue	if	their	local	curvature
would	go	beyon	60	degrees)

-       ‘Min	Length(mm)’:	50.0	(streamline	are	not	accepted	if	their	length	is	less



than	50	mm)
-       ‘Terminate	if’:5000’,	‘Tracts’	(maximum	number	of	streamlines)

·      Start	streamlines	algorithm	by	clicking	Fiber	Tracking
-       Note	that	this	is	very	demanding	task	and	the	software/VM	may	crash
-       If	that	happens,	re-start	and	reduce	the	number	of	tracks

·      Save	screenshot(s)	in	orthogonal	views
·      Save	basic	tractogram	statistics	(Tracts	>	Statistics	>	Save)

	
14.             (Tracktography	with	correcte	DTI	dataset)	With	DSIstudio:

1.   Create	tractogram	as	in	the	previous	step	(if	you	changed	the	tracking	parameters,	use
the	same	ones	here	for	consistency),	but	with	the	corrected	image:
Hands_on_data_v1/eddy_outputs_precalculated/eddy_outputs.nii.gz
Hands_on_data_v1/bvals
Hands_on_data_v1/eddy_outputs_precalculated/eddy_outputs.eddy_rotated_bvecs

2.   As	in	previous	step,	save	screenshot(s)	in	orthogonal	views,	and	tractogram	statistics
	

15.             (Comparison	of	DTI	tracktography	before	and	after	corrections)
-       Looking	at	screenshots	and	statistics	side-by-side,	do	you	see	any	major	differences	(e	g
more	than	10%	difference	in	metrics)?

	
At	this	point,	you	have	gone	through	DTI	image	processing,	including	quality	control	for	individual
case.	Optionally,	the	hands-on	data	contains	another	repetition	of	the	exact	same	case,	the	test-
retest	repeatability	can	be	calculated	by	running	the	process	with	that	data	as	well,	and	comparing
the	results	(the	numbers	should	be	the	same	in	absolute	sense	since	they	come	from	the	same
scanner	with	the	same	subject	with	negligible	timespan	between	scans).


